最新記事

Debian sidにパスを再インストールする
debian
gpg

Debian sidにパスを再インストールする

pass私のDebian SID設定から最近削除されました。GPG(例dirmngr gpg gpg-agent gpg-wks-client gpgsm gpgconf gpgv:)不安定なバージョン2.2.40-3にアップグレードされました。 この時点で再インストールするには2.2.40.1にpassダウングレードが必要です。削除しないでください他のいくつかのパッケージを削除せずにgpgダウングレードするためのきちんとした方法はありますか?apt-get エラー履歴: #apt install pass Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: Unsatisfied dependencies: gnupg : Depends: dirmngr (< 2.2.40-1.1.1~) but 2.2.40-3 is to be installed Depends: gpg-agent (< 2.2.40-1.1.1~) but 2.2.40-3 is to be installed Depends: gpg-wks-client (< 2.2.40-1.1.1~) but 2.2.40-3 is to be installed Depends: gpg-wks-server (< 2.2.40-1.1.1~) but it is not going to be installed Depends: gpg-wks-server (>= 2.2.40-1.1) but it is not going to be installed Depends: gpgsm (< 2.2.40-1.1.1~) but 2.2.40-3 is to be installed Error: Unable to correct problems, you have held broken packages. apt policy gnupgプログラム gnupg: Installed: (none) Candidate: 2.2.40-1.1 Version table: 2.2.40-3 200 […] sid/main […] 2.2.40.1.1 500 […] bookworm/main […] 私は最近、次のDebianリリースの一部としてsidからテストに切り替えるために、testingピンの優先順位を500(sid200)に設定しました。/etc/apt/preferences

Admin

SSDが切断されるたびに再起動し、正しい起動デバイスを選択してください。 SSDエラー
debian
grub
uefi
boot-loader

SSDが切断されるたびに再起動し、正しい起動デバイスを選択してください。 SSDエラー

私は見つけたがこれを一度に行う方法、問題が再発生しました。だとしたら質問が残ります。 AAEON EMB-BT1 itxボードのSATAポートからSSDを取り外すたびに起動が拒否され、このエラーが発生するのはなぜですか?私のオペレーティングシステムはDebian Linuxであり、SSDを交換するたびにgrub-efiを再インストールすることはできません。 これは私のパーティションです。ゼロ以外の2048で始まるEFIシステムに関連している可能性がありますか?しかし、これはDebian Partition Managerが設定する方法です。 grub-efi 再インストール処理後のディスクの状態は次のとおりです。 明らかに、Boot0001 *オプションが機能せず、マザーボードからSSDを取り外すと、Boot0000 * debianエントリが消去されます。私はなぜ、どのように理解していません。 編集:起動時にACPIバスエラーもあります。

Admin

パッケージマネージャのプレインストールスクリプト「インストール」と「アップグレード」
debian
packaging

パッケージマネージャのプレインストールスクリプト「インストール」と「アップグレード」

Debianパッケージによるとメンテナンススクリプト文書install、プリインストールスクリプトは、最初の引数または最初の引数を使用して呼び出すことができますupgrade。 スクリプトpreinstは次のように呼び出すことができます。 new-preinstインストールする new-preinstインストールする旧バージョン 新バージョン new-preinstアップグレード旧バージョン 新バージョン install old-version new-versionこれらとそしての違いは何ですかupgrade old-version new-version?最初の形式(ちょうどinstall)ははっきりしているようですが、古いバージョン番号と新しいバージョン番号の違いinstallとそれをどこに指定するのか理解できません。upgrade

Admin

Debian Backport: ブルズアイのバックポートで利用可能なすべてのアップグレードを一覧表示する方法
debian
apt
backports

Debian Backport: ブルズアイのバックポートで利用可能なすべてのアップグレードを一覧表示する方法

私は成功せずに検索しました。方法到着リストDebianバックポート(特にbullseye-backports)が提供するすべてのアップグレード: deb http://deb.debian.org/debian bullseye-backports main contrib non-freeに追加しました/etc/apt/sources.list。 sudo apt update正常に実行しました 私の仕事の結果はsudo apt list --upgradeable bullseye-backports「空」です。 実行しましたが、sudo apt list --upgradeable -t bullseye-backportsエラーが発生しました。 これを実行しましたsudo apt -t bullseye-backports upgrade。インストールする新しいパッケージのリスト、アップグレードする既存のパッケージのリスト、および展開全体を引き続き[Y/n]処理するオプションが表示されます。 簡単にする方法はないでしょうかリストからアップグレード可能なパッケージbullseye-backports?

Admin

Debian 11 から virtualenv を削除できません
debian
python
python3
virtualenv

Debian 11 から virtualenv を削除できません

私のDebianオペレーティングシステムは何度もアップグレードされ、現在バージョン11(Bullseye)です。もともとそれから始めましたが、python2今はもう欲しくありません。ただそうですpython3。virtualenvずっと前に設置してまだ使っていましたpython2。 私は完全な仕事をしましたdist-upgrade。 $ sudo apt-get update Hit:1 http://deb.debian.org/debian bullseye InRelease Get:2 https://deb.nodesource.com/node_14.x bullseye InRelease [4,586 B] Get:3 http://deb.debian.org/debian-security bullseye-security InRelease [48.4 kB] Hit:4 http://deb.debian.org/debian bullseye-updates InRelease Fetched 53.0 kB in 1s (49.9 kB/s) Reading package lists... Done $ sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree... Done Reading state information... Done Calculating upgrade... Done The following packages have been kept back: libts-dev 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. インストールされていることを確認してみると、virtualenv次のようになります。 $ which virtualenv /usr/local/bin/virtualenv アンインストールしようとしたがインストールされpipていないというメッセージが表示されます。 $ pip uninstall virtualenv WARNING: Skipping virtualenv as it is not installed $ sudo pip uninstall virtualenv WARNING: Skipping virtualenv as it is not installed. $ pip3 uninstall virtualenv WARNING: Skipping virtualenv as it is not installed $ sudo pip3 uninstall virtualenv WARNING: Skipping virtualenv as it is not installed. もしこのようにインストールされた場合は、パッケージマネージャを使ってアンインストールしてみました。 $ sudo apt-get remove virtualenv --purge Reading package lists... Done Building dependency tree... Done Reading state information... Done Package 'virtualenv' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. しかし、最終的にはまだインストールされていることがわかります。 $ which virtualenv /usr/local/bin/virtualenv 削除する理由は、実行しようとしたときにエラーが発生するためです。完全にアンインストールして再インストールすると、この問題が解決するかどうかを考えています。 $ virtualenv . Traceback (most recent call last): File "/usr/local/bin/virtualenv", line 7, in from virtualenv import main ModuleNotFoundError: No module named 'virtualenv' 削除する必要がありますか/usr/local/bin/virtualenv?これは悪い考えのようです。パッケージマネージャを使用して削除する方法はvirtualenv? アップデート1 - 以下virtualenvを使用してインストールを試みました。pip3 インストールは成功しましたが、virtualenvまだ実行できず、エラーは報告されません。 $ pip3 install virtualenv Defaulting to user installation because normal site-packages is not writeable Collecting virtualenv Using cached virtualenv-20.25.1-py3-none-any.whl.metadata (4.4 kB) Requirement already satisfied: distlib<1,>=0.3.7 in ./.local/lib/python3.9/site-packages (from virtualenv) (0.3.8) Requirement already satisfied: filelock<4,>=3.12.2 in ./.local/lib/python3.9/site-packages (from virtualenv) (3.13.3) Requirement already satisfied: platformdirs<5,>=3.9.1 in ./.local/lib/python3.9/site-packages (from virtualenv) (4.2.0) Using cached virtualenv-20.25.1-py3-none-any.whl (3.8 MB) Installing collected packages: virtualenv WARNING: The script virtualenv is installed in '/home/me/.local/bin' which is not on PATH. Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location. Successfully installed virtualenv-20.25.1 $ which virtualenv /usr/local/bin/virtualenv $ virtualenv --version Traceback (most recent call last): File "/usr/local/bin/virtualenv", line 7, in from virtualenv import main ImportError: cannot import name 'main' from 'virtualenv' (/home/me/.local/lib/python3.9/site-packages/virtualenv/__init__.py) $ virtualenv . Traceback (most recent call last): File "/usr/local/bin/virtualenv", line 7, in from virtualenv import main ImportError: cannot import name 'main' from 'virtualenv' (/home/me/.local/lib/python3.9/site-packages/virtualenv/__init__.py) これで、virtualenvファイルシステムの2つの場所に存在します。 $ which virtualenv /usr/local/bin/virtualenv $ sudo find /usr/ -iname "virtualenv" | grep bin /usr/local/bin/virtualenv $ sudo find /home/me/.local/ -iname "virtualenv" | grep bin /home/me/.local/bin/virtualenv $ ls -l /home/me/.local/bin/virtualenv -rwxr-xr-x 1 me me 238 Apr 7 13:06 /home/me/.local/bin/virtualenv

Admin

KDEがインストールされているDebian 12は端末でアプリケーションを実行できません
debian
terminal
kde

KDEがインストールされているDebian 12は端末でアプリケーションを実行できません

ルートまたは他のユーザーとして端末でアプリケーションを実行しようとすると、次のメッセージが表示されます。 qt.qpa.xcb: could not connect to display qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem. Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Admin

docker-compose.yml環境が.envファイルの内容を上書きするのはなぜですか?
debian
environment-variables
node.js

docker-compose.yml環境が.envファイルの内容を上書きするのはなぜですか?

設定を使用するドッカーコンテナがあり、docker-compose.ymlここにいくつかの環境変数が導入されました。 environment: - AUTH_SECRET=some_secret その後、私のファイルには次の値があります.env。 AUTH_SECRET=another_secret 問題は私のQwikアプリケーションで.envファイルがdocker-compose.yml。 人々は期待するでしょう詳細取り扱うべき項目あまり具体的ではなく、より一般的です。オペレーティングシステム これは私のコードです。 import { serverAuth$ } from '@builder.io/qwik-auth' import type { Provider } from '@auth/core/providers' import Keycloak from '@auth/core/providers/keycloak' export const { onRequest, useAuthSession, useAuthSignin, useAuthSignout } = serverAuth$( ({ env }) => ({ secret: env.get("AUTH_SECRET"), trustHost: true, callbacks: { async session({ session, token, }){ session.user.guid = token.sub return session } }, providers: [ Keycloak({ clientId: 'Site', clientSecret: env.get('KEYCLOAK_CLIENT_SECRET') as string, issuer: env.get('KEYCLOAK_ISSUER') as string }), ] as Provider[], }) ); 私のコードでは、代わりsome_scerentにが表示されますanother_secret。 この動作は正常ですか?特定のアプリケーションでシステム全体の環境変数をどのようにオーバーライドできますか?

Admin

i3wmでパスワードなしで休止状態でDebian 12を設定する方法
linux
debian

i3wmでパスワードなしで休止状態でDebian 12を設定する方法

最近Debian 12にアップグレードしましたが、一定期間活動がない場合は、ロック画面からロックを解除するにはパスワードを入力する必要があることがわかりました。私は自宅のコンピュータを使用しており、この動作は必要ありませんが、オンラインで回答を見つけようとした後でもこの動作を無効にする方法がわかりません。この問題を解決する方法についてアドバイスを求めることはできますか?ありがとう

Admin

DebianのlighttpdでIPv6リスニングアドレスを制限する方法
debian
ipv6
lighttpd

DebianのlighttpdでIPv6リスニングアドレスを制限する方法

私はDebianシステムのlocalhostでのみlighttpdを使用できるようにしようとしています。次の行は次の場所にあります。/etc/lighttpd/lighttpd.conf server.port = 80 server.bind = "127.0.0.1" server.use-ipv6 = "disable" ただし、WebサーバーはすべてのIPv6アドレスでも実行されます。 # netstat -tupan|grep lighttpd tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN 519887/lighttpd tcp6 0 0 :::80 :::* LISTEN 519887/lighttpd 構成ファイルで以前に印刷された行の代わりに次の行を使用すると、サーバーは起動しません。 server.bind = "[::1]" つまり、使用中のポートに関するエラーメッセージのみが表示されますが、ポートは使用中ではありません。 # netstat -tupan|grep LISTEN|grep 80/; lighttpd -f /etc/lighttpd/lighttpd.conf; netstat -tupan|grep LISTEN|grep 80/ 2023-04-27 16:50:24: (network.c.537) can't bind to socket: [::1]:80: Address already in use lighttpdがlocalhostでのみ受信するように制限する方法(IPv4のみ、IPv6のみ、またはIPv4およびIPv6)

Admin

Debian 11/Q4OS Centaurusに
debian
apt
dependencies

Debian 11/Q4OS Centaurusに "build-essential"パッケージをインストールしようとしたときにエラーを修正する方法は?

sudo apt install build-essential Reading package lists... Done Building dependency tree... Done Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libr0 : Depends: libbinutils (< 2.31.2) but 2.35.2-2 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. apt policy libr0プログラム libr0: Installed: 4:14.0.6-0debian10.0.0+0~a Candidate: 4:14.0.6-0debian10.0.0+0~a Version table: *** 4:14.0.6-0debian10.0.0+0~a 500 500 http://q4os.org/qtderepo buster/main amd64 Packages 100 /var/lib/dpkg/status apt policy libbinutilsプログラム libbinutils: Installed: 2.31.1-16 Candidate: 2.35.2-2 Version table: 2.35.2-2 500 500 http://ftp.de.debian.org/debian bullseye/main amd64 Packages *** 2.31.1-16 500 500 http://ftp.debian.org/debian buster/main amd64 Packages 100 /var/lib/dpkg/status libbinutils結果をアップグレードしてみてください WARNING: The following essential packages will be removed. This should NOT be done unless you know exactly what you are doing! q4os-desktop tdelibs14-trinity (due to q4os-desktop) tdebase-trinity-bin (due to q4os-desktop) tdesudo-trinity (due to q4os-desktop) tde-style-q4oststyle02-trinity (due to q4os-desktop) twin-trinity (due to q4os-desktop) network-manager-tde (due to q4os-desktop

Admin

エラーを引き起こすカスタム Nexus apt リポジトリの設定
debian
apt

エラーを引き起こすカスタム Nexus apt リポジトリの設定

Sonatype nexusでホストされているaptリポジトリが設定されており、それを自分のローカルDebianコンピュータで設定しようとしています。 /etc/apt/sources.list.d/cust-repository.list文書: deb [trusted=yes] https://nexusrepourl.org/repository/apt/ bullseye main apt-getアップデートを実行しようとすると、次のエラーが発生します。 Err:7 https://nexusrepourl.org/repository/apt bullseye/main amd64 Packages 404 dists/bullseye/main/binary-amd64/Packages.xz [IP: xx.xx.xx.xxx 443] Ign:8 https://nexusrepourl.org/repository/apt bullseye/main all Packages Ign:9 https://nexusrepourl.org/repository/apt bullseye/main Translation-en Reading package lists... Done E: Failed to fetch https://nexusrepourl.org/repository/apt/dists/bullseye/main/binary-amd64/Packages 404 dists/bullseye/main/binary-amd64/Packages.xz [IP: xx.xx.xx.xxx 443] E: Some index files failed to download. They have been ignored, or old ones used instead. /var/lib/apt/lists/から公式文書に記載されているすべてのファイルを削除しました。https://help.sonatype.com/en/apt-repositories.html 誰もがこの問題を解決する方法を理解するのに役立ちます。ありがとうございます。

Admin